What version of Android do I need to have to use the iHeartRadio app?

Last Updated: Oct 23, 2013 12:06PM EDT

You'll need an Android device running Android version 2.3 or higher. After downloading and installing the application, you'll need to be connected to a cellular data network or WiFi in order to use iHeartRadio.

For help finding out what version of Android you're using view our article here.

support@iheartradio.com
http://assets04.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete